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This 

 

Galaxy Plus Editors

 

 module adds support for the 
Yamaha TG500. This manual describes only features specific to the 
TG500 Editor. See your Galaxy manual for information on:

• Installing Editor and Librarian modules;
• Loading/sending Bundles, Banks, and Patches;
• Using common editing features such as graphic envelopes, pop-up 

menus, and numericals.

You should also read the “device specific” online Help, which is 
available from the Apple 

 

Help

 

 menu when a Bank, Bundle, or Edit 
Window is active.

 

TG500

 

The Yamaha TG500 is a sample-playback synthesizer with PCM 
waveforms, digital resonant filtering, and digital effects processing. 
The TG500 Editor module lets you make alterations to the sounds 
and settings with intuitive, full-size graphic windows.

 

A

 

BOUT

 

 T

 

HIS

 

D

 

OCUMENT

 

This manual does not attempt to teach programming for the TG500 
and it does not discuss each parameter in detail. Often, the effect of 
one parameter depends on the settings of other parameters. If you 
alter a parameter and don’t hear any change in sound, examine how 
other parameters may affect the desired outcome. Refer to your 
Yamaha manual to learn how various parameters interact and affect 
the overall sound.
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CH 1: INTRODUCTION

 

INSTRUMENT SETUP

 

Before using the Yamaha TG500 with Galaxy Plus Editors make sure:

• The instrument’s MIDI input 

 

and

 

 output are connected to your MIDI 
interface; if using a multiport interface, connect both MIDI cables to 
the same port number;

• The TG500’s 

 

DevNo 

 

(Device number) matches the Device ID setting 
in your OMS Studio Setup;

• The TG500’s 

 

BulkPr 

 

(Bulk receive protect) setting is “OFF.”

For more details on configuring the TG500, please consult your 
Yamaha manual.

 

?

 

See also Galaxy’s “device specific” online Help, available from the 
Apple 

 

Help

 

 menu when a Bank, Bundle, or Edit Window is active.

 

CREATING A NEW BUNDLE

 

To open a new Bundle for the Yamaha TG500:

 

a

 

Make sure your 

 

Current

 

 OMS Studio Setup contains a TG500, then launch Galaxy 
Plus Editors.

When launching Galaxy for the first time, Librarian modules for devices contained 
in your OMS Studio Setup are automatically installed.

 

b

 

Choose 

 

File>New Bundle

 

.

A dialog box listing all installed Librarian modules appears.

 

c

 

Select the TG500 device and click 

 

OK

 

.

The default TG500 Bank types are placed in a new “Untitled” Bundle.

When opening or a creating a Bundle, a Bundle menu becomes available in 
Galaxy; to retrieve all Banks from your instrument, choose 

 

Bundle>Get All Banks 
in Bundle

 

.
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B

 

ANK

 

 T

 

YPES

 

Below is a brief description of each 

 

TG500

 

 Bank type:

 

Figure 1: TG500 Bundle

 

A

 

Performances

 

: Bank of 64 Performances, each composed of up to 4 
layers assigned to Voices (with Effects settings).

 

B

 

Voices, Int1/2

 

: Two Banks (Internal 1and Internal 2) of 63 Voices. 
Voices consist of a single waveform along with settings for ampli-
tude, filter, pitch, and LFO. Voices also have their own Effects 
settings.

 

C

 

Drum, Int1/2

 

: Two Drum Voices (Internal 1 and Internal 2), each 
with drum/percussion sounds assigned to keys within a 61-note 
range (C1-C5).

 

D

 

Multis

 

: Bank of 16 Multis, each composed of up to 16 parts assigned 
to Voices, Performances, and Drum Voices.

 

E

 

Synth Setup

 

: Specifies global settings for note shift, tuning, and 
MIDI parameters.
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CH 2: VOICES

 

To edit a TG500 Voice:

 

a

 

Open a Bank of Voices

Figure 2: Voice Bank

 

b

 

Highlight the desired Patch and click the 

 

Edit

 

 button.

The selected Voice is sent to the TG500’s edit buffer and the Voice Edit Window 
opens as shown in Figure 3.

 

VOICE EDIT WINDOW

 

A Voice is the most basic Patch type for the TG500. It consists of a 
single oscillator assigned to a waveform, along with settings for 
filter, amplitude, pitch and LFO.

 

Figure 3: Voice Edit Window

 

Following is a brief description of Voice Edit Window components:
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A

 

Voice Level, Effect Send Level

 

: Sets the Voice level and Effects send 
level.

 

B

 

Oscillator

 

: Assigns waveform and tuning for the Voice.

 

C

 

Filter

 

: Determines filter type along with settings for cutoff frequency 
and resonance, which can be modulated by an envelope generator, 
velocity sensitivity, and key scaling.

 

D

 

Amp EG

 

: Sets parameters affecting amplitude, which include an 
envelope generator, velocity sensitivity, and key scaling.

 

E

 

Pitch EG

 

: Sets parameters affecting pitch, which include an envelope 
generator and velocity sensitivity.

 

F

 

Effects

 

: Click this button to open the Effects Edit Window.

 

G

 

LFO

 

: Determines LFO waveform and related parameters (speed, 
phase, and delay). There are also settings for LFO destinations and 
LFO modulators (control sources affecting LFO parameters).

 

C

 

OPYING

 

 V

 

OICE

 

C

 

OMPONENTS

 

Specific components of a Voice can be copied/pasted from the Voice 
Edit Window. Simply click on the text heading for 

 

Oscillator

 

, 

 

Filter

 

, 

 

Amp EG

 

, 

 

Pitch EG

 

, or 

 

LFO

 

 to highlight the desired component and 
its parameters.

 

Figure 4: Filter parameters selected

 

W

 

ORKING

 

 

 

WITH

 

E

 

NVELOPE

 

G

 

ENERATORS

 

The Voice Edit Window contains small graphic envelope displays 
for filter, amplitude, and pitch. Clicking on any of these small 
graphic envelopes opens a larger, editable envelope display.

 

Figure 5: Amplitude Envelope Generator, Small Display

Click here to open large envelope display.
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In the large display, envelopes can easily be edited by dragging 
envelope points with the mouse; envelope 

 

rates

 

 and 

 

levels

 

 may also 
be edited by changing their numeric displays.

 

Figure 6: Amplitude Envelope Generator, Large Display

 

Consult your Galaxy Plus Editors manual for more information on 
working with envelope generators.

 

MIDIBAR

 

With the Voice Edit Window active, choose 

 

Edit>MIDIBar

 

 to open 
the MIDIBar Window. The MIDIBar allows you to make quick, 
single-click edits to commonly “tweaked” parameters (such as enve-
lopes, filter cutoff, key velocity, and octave range). Click on the 
“MIDI Bar” text to get a help screen explaining each icon.

 

Figure 7: MIDIBar Window

 

Click anywhere in the MIDIBar help screen to close it.

Edit rates and levels
by changing numericals.

Drag envelop points
to edit envelope.

Click here for help.
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CONTROLS EDIT WINDOW 

 

With the Voice Edit Window active, choose 

 

Edit>Controls

 

 to edit 
how a Voice responds to continuous controller information.

 

Figure 8: Controls Edit Window

 

Bend range

 

 can be specified for both pitch wheel and After Touch. 

 

Controller

 

 sources (After Touch, MC1, MC2) can be routed to desti-
nations (pitch, amplitude, frequency modulation, cutoff frequency, 
and EG bias) with individual depth settings. MC3 and MC4 can be 
routed to an even wider variety of Voice parameters.

 

?

 

MC1-5 are defined in the TG500 Synth Setup. See Synth Setup Edit 
Window (pg. 14).

 

EFFECTS EDIT WINDOW

 

With the Voice Edit Window active, choose 

 

Edit>Edit Effects

 

 to edit 
Voice Effects settings.

 

Figure 9: Effects Edit Window

 

Following is a description of the Effects Edit Window components:
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A Effect Mode: The Effect Mode pop-up determines the configuration 
(serial, parallel, or off) of the effects processors. The configuration 
and display of the routing (complete with level settings) will vary 
depending on the Effect Mode and effect types used.

B Effect 1/2: Specifies any of 90 effect types (including some dual 
effects) for both Effect 1 and Effect 2. The parameters and values dis-
played will vary depending on the chosen effect.

C Controllers: Routes controllers to the specified effect parameters.
D LFO: Configures LFO parameters, which are used in conjunction 

with certain modulation-type effects (chorus, flange, etc.).



Ch 3: Drum Voices - 8 - TG500 Editor

CH 3: DRUM VOICES

To edit a TG500 Drum Voice:

a Open a TG500 Drum Bank.

Figure 10: Drum Bank

b Click the Edit button to open the Drum Voice Edit Window.

DRUM VOICE EDIT WINDOW

A Drum Voice consists of a collection of drum and percussion 
sounds assigned to MIDI notes (drum keys) ranging from C1-C5. 
Each drum key may be independently routed to Effects 1 and 2.

Figure 11: Drum Voice Window

Following is a brief description of the components that make up the 
Drum Voice Edit Window:

A Level: Sets the overall volume level for the Drum Voice.
B Note Column: Indicates the MIDI note for the edited drum key. 

Drum Voices span a range of 61 notes (C1-C5). Clicking a note name 
selects the entire line for copying or pasting.
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C Keyboard: The column to the right of the note names is a scrollable 
keyboard for auditioning sounds. Clicking any note on the keyboard 
triggers the corresponding sound.
Clicking the up/down arrows scrolls the display an octave at a time. 
Option-clicking an arrow, scrolls one note at a time. The velocity of 
the MIDI note played is set with the Mac KV setting in the 
MouseKeys Window.

D Drum key parameters: Assigns to each drum key a waveform along 
with settings for level, pan, shift, tune, output select and effect sends.

When receiving a note from your MIDI keyboard controller, Galaxy 
automatically scrolls to the corresponding drum key.

E Effects: Click this button to open the Effects Edit Window for the 
Drum Voice.

Consult the TG500 manual for a complete description of Drum Voice 
parameters.

DRUM VOICE
EFFECTS

With the Drum Voice Edit Window active, choose Edit>Edit Effects 
to edit its Effects settings. The Effects Edit Window for Drum Voices 
is identical to that for Voices. For more information see Effects Edit 
Window (pg. 6).

Whether a particular drum key is processed is determined by the 
Effects Send check boxes in the Drum Voice Edit Window.
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CH 4: PERFORMANCES

To edit a TG500 Performance:

a Open a Performance Bank.

Figure 12: Performance Bank

b Highlight the desired Patch and click the Edit button.

Galaxy sends the Performance to the TG500’s edit buffer and opens the Perfor-
mance Edit Window as shown in Figure 13.

PERFORMANCE EDIT WINDOW

The Performance Edit Window displays the layers (which are 
assigned to Voices) that make up a TG500 Performance. Perfor-
mances are used to create keyboard splits and layers.

Figure 13: Performance Edit Window

1

2

3

4

5



Ch 4: Performances - 11 - TG500 Editor

Following is a brief description of each component in the Perfor-
mance Edit Window:

A Layers: Up to 4 Voices are assigned to layers, along with settings for 
volume, pan, tune, shift, and effects sends.

B Quick Edit: Provides easy access to editing Voice parameters, which 
include amplitude, filer, and LFO settings.

C Ranges: Determines velocity and key ranges for each layer. Key 
ranges can be set graphically by dragging over the keyboard 
displays.

D Effects: This button opens the Effects Edit Widow for the current 
Performance.

E Performance Level: Sets the overall volume level for the 
Performance.

For detailed a explanation of all Performance parameters, please 
consult your TG500 manual.

COPYING LAYERS To select a layer for copying/pasting, simply click its letter (A, B, C, 
or D). Layer parameters can be copied to another layer (within the 
same Performance) or to a different Performance.

Figure 14: Select layer by clicking it letter

PERFORMANCE
EFFECTS

With the Performance Edit Window active, choose Edit>Edit Effects 
to edit a Performance’s Effects settings. The Effects Edit Window for 
Performances is identical to that for Voices. For more information 
see Effects Edit Window (pg. 6).

? NOTE: When a Voice is used within a Performance, the Voice’s orig-
inal Effects settings are ignored. Whether a layer (Voice) is 
processed is determined by the Effects Send check boxes in the Per-
formance Edit Window.
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CH 5: MULTIS

To edit a TG500 Multi:

a Open a Bank of Multis.

Figure 15: Multi Bank

b Highlight the desired Patch and click the Edit button to open the Multi Edit 
Window.

MULTI EDIT WINDOW

Multis can have up to 16 parts, which are assigned Performances, 
Voices, and Drum Voices. Multis are extremely useful when utilizing 
the TG500 as a multi-timbral sound module.

Figure 16: Multi Edit Window
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The parts within a Multi can be assigned settings for volume, pan, 
tune, octave shift, output and effects sends. Graphic faders, located 
at the bottom of the Multi Edit Window, provide an easy way of set-
tings levels for the 16 parts.

? IMPORTANT: If desired, Effects and output settings for a part can 
use the settings of the original Performance, Voice, or Drum Voice.

COPYING PARTS To select a part for copying/pasting, simply click its number (1-16). 
Part parameters can be copied to another part (within the same 
Multi) or to a different Multi.

MULTI EFFECTS With the Multi Edit Window active, choose Edit>Edit Effects to edit 
a Multi’s Effects settings. The Effects Edit Window for Multis is iden-
tical to that for Voices. For more information see Effects Edit 
Window (pg. 6).
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CH 6: SYNTH SETUP

To edit Synth Setup for the TG500:

a Open the Synth Setup Bank.

b Click the Edit button to open the Synth Setup Edit Window.

SYNTH SETUP EDIT WINDOW

Figure 17: Synth Setup Edit Window

The Synth Setup includes the following global parameters:

A Systems: Configures global settings for octave shift, fine tuning, and 
receive channel.

B Switches: Determines whether the TG500 responds to the specified 
messages.

C Controls & Settings: Sets how the TG500 responds to program 
change and bank select messages. Additionally, a set of four global 
control sources (MIDI Control 1-4) are defined.

Refer to the TG500 manual for a more detailed description of the 
Synth Setup parameters.
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